Nov 212013
 

For some time, I’ve seen these messages and been slightly bothered by them. Today, I found the solution.

can't re-use a leaf (geom_label)!
can't re-use a leaf (geom_part_gpt)!
module_register: module g_label already exists!
Module g_label failed to register: 17
module_register: module g_part_gpt already exists!
Module g_part_gpt failed to register: 17

Those messages appeared on the console while booting and were logged in /var/log/dmesg.boot. I was told, but I forget where, that this was because I was specifying modules which were already loaded.

Today I went to /boot/loader.conf and removed the following:

geom_label_load="YES"
geom_part_gpt_load="YES"

I rebooted the server. All came back fine. No more messages. Fixed.

NOTE: the original post also showed removing geom_eli_load and geom_mirror_load, which I believe would be incorrect.

Website Pin Facebook Twitter Myspace Friendfeed Technorati del.icio.us Digg Google StumbleUpon Premium Responsive