NOTE: If you’re looking for a jail configuration for poudriere, please refer to Configuration for running poudriere in a jail on FreeBSD 14.
I recently moved the pkg01 jail from one host to another. I’m having trouble getting it to build packages.
[pkg01 dan ~] % sudo poudriere testport -j 131amd64 -p dvl -z primary -i devel/py-pip [00:00:00] Error: Please load the linux module on the host using "kldload linux"
On the host:
[r730-01 dvl /etc/jail.conf.d] % sudo kldload linux
I tried again:
[pkg01 dan ~] % sudo poudriere testport -j 131amd64 -p dvl -z primary -i devel/py-pip [00:00:00] Error: Please load the linux64 module on the host using "kldload linux64"
[r730-01 dvl /etc/jail.conf.d] % sudo kldload linux64 [r730-01 dvl /etc/jail.conf.d] % sudo service jail restart pkg01
I am sure I didn’t need to restart the jail
[pkg01 dan ~] % sudo poudriere testport -j 131amd64 -p dvl -z primary -i devel/py-pip [00:00:00] Creating the reference jail... done [00:00:03] Mounting system devices for 131amd64-dvl-primary [00:00:03] Mounting ports/packages/distfiles
What confuses me is how I missed this need. I looked at /boot/loader.conf on the original host (slocum) and there is no mention of linux in there. My question is: how is the kernel module getting loaded on that host?
Oh there it is:
[r720-01 dan ~] % sysrc kld_list kld_list: aesni linux linux64
Complicating the search, I was looking on the wrong host. pkg01 came over from r720-01, not slocum.
Once I duplicated that setting in the new host, and rebooted, building was OK.
In addition, those settings also fixed this issue:
fatal: detected dubious ownership in repository at '/usr/local/poudriere/data/.m/131amd64-dvl-primary/ref/usr/ports' To add an exception for this directory, call: git config --global --add safe.directory /usr/local/poudriere/data/.m/131amd64-dvl-primary/ref/usr/ports fatal: detected dubious ownership in repository at '/usr/local/poudriere/data/.m/131amd64-dvl-primary/ref/usr/ports' To add an exception for this directory, call:
On to the next issue.